]> git.tdb.fi Git - gldbg.git/blob - glx.spec
Track vertex array state
[gldbg.git] / glx.spec
1 # Copyright (C) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
2 #
3 # This document is licensed under the SGI Free Software B License Version
4 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
5
6 required-props:
7 param:          retval retained
8 dlflags:        notlistable handcode nop
9 glxflags:       client-handcode server-handcode
10 glxvendorglx:   *
11 vectorequiv:    *
12 category:       pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
13 glxopcode:              *
14
15 ###############################################################################
16 #
17 # GLX1.0 commands
18 #
19 ###############################################################################
20 Render()
21         return           void
22         category         glx
23         dlflags          notlistable
24         glxflags         client-handcode server-handcode
25         glxopcode        1
26
27
28 RenderLarge()
29         return           void
30         category         glx
31         dlflags          notlistable
32         glxflags         client-handcode server-handcode
33         glxopcode        2
34
35
36 CreateContext(dpy, visual, share_list, direct)
37         return           GLXContext
38         param            dpy            DisplayPointer in value
39         param            visual         XVisualInfoPointer in value
40         param            share_list     GLXContext in value
41         param            direct         Bool in value
42         glxflags         client-handcode server-handcode
43         category         glx
44         dlflags          notlistable
45         glxopcode        3
46
47
48 DestroyContext(dpy, ctx)
49         return           void
50         param            dpy            DisplayPointer in value
51         param            ctx            GLXContext in value
52         glxflags         client-handcode server-handcode
53         category         glx
54         dlflags          notlistable
55         glxopcode        4
56
57
58 MakeCurrent(dpy, drawable, ctx)
59         return           Bool
60         param            dpy            DisplayPointer in value
61         param            drawable       GLXDrawable in value
62         param            ctx            GLXContext in value
63         category         glx
64         dlflags          notlistable
65         glxopcode        5
66
67
68 IsDirect(dpy, ctx)
69         return           Bool
70         param            dpy            DisplayPointer in value
71         param            ctx            GLXContext in value
72         glxflags         client-handcode server-handcode
73         category         glx
74         dlflags          notlistable
75         glxopcode        6
76
77
78 QueryVersion(dpy, major, minor)
79         return           Bool
80         param            dpy            DisplayPointer in value
81         param            major          int out reference
82         param            minor          int out reference
83         category         glx
84         dlflags          notlistable
85         glxflags         client-handcode server-handcode
86         glxopcode        7
87
88
89 WaitGL()
90         return           void
91         category         glx
92         dlflags          notlistable
93         glxflags         client-handcode server-handcode
94         glxopcode        8
95
96
97 WaitX()
98         return           void
99         category         glx
100         dlflags          notlistable
101         glxflags         client-handcode server-handcode
102         glxopcode        9
103
104
105 CopyContext(dpy, source, dest, mask)
106         return           void
107         param            dpy            DisplayPointer in value
108         param            source         GLXContext in value
109         param            dest           GLXContext in value
110         param            mask           ulong in value
111         category         glx
112         dlflags          notlistable
113         glxflags         client-handcode server-handcode
114         glxopcode        10
115
116
117 SwapBuffers(dpy, drawable)
118         return           void
119         param            dpy            DisplayPointer in value
120         param            drawable       GLXDrawable in value
121         category         glx
122         dlflags          notlistable
123         glxflags         client-handcode server-handcode
124         glxopcode        11
125
126
127 UseXFont(font, first, count, list_base)
128         return           void
129         param            font           Font in value
130         param            first          int in value
131         param            count          int in value
132         param            list_base      int in value
133         category         glx
134         dlflags          notlistable
135         glxflags         client-handcode server-handcode
136         glxopcode        12
137
138
139 CreateGLXPixmap(dpy, visual, pixmap)
140         return           GLXPixmap
141         param            dpy            DisplayPointer in value
142         param            visual         XVisualInfoPointer in value
143         param            pixmap         Pixmap in value
144         category         glx
145         dlflags          notlistable
146         glxflags         client-handcode server-handcode
147         glxopcode        13
148
149 GetVisualConfigs()
150         return           void
151         category         glx
152         dlflags          notlistable
153         glxflags         client-handcode server-handcode
154         glxopcode        14
155
156
157 DestroyGLXPixmap(dpy, pixmap)
158         return           void
159         param            dpy            DisplayPointer in value
160         param            pixmap         GLXPixmap in value
161         glxflags         client-handcode
162         category         glx
163         dlflags          notlistable
164         glxopcode        15
165
166
167 VendorPrivate()
168         return          void
169         glxflags        client-handcode server-handcode
170         category        glx
171         dlflags         notlistable
172         glxopcode       16
173
174
175 VendorPrivateWithReply()
176         return          void
177         glxflags        client-handcode server-handcode
178         category        glx
179         dlflags         notlistable
180         glxopcode       17
181
182 ###############################################################################
183 #
184 # GLX1.1 commands
185 #
186 ###############################################################################
187 QueryExtensionsString(dpy, screen)
188         return          GLXstring
189         param           dpy             DisplayPointer in value
190         param           screen          int in value
191         glxflags        client-handcode server-handcode
192         category        glx
193         dlflags         notlistable
194         glxopcode       18
195
196 QueryServerString(dpy, screen, name)
197         return          GLXstring
198         param           dpy             DisplayPointer in value
199         param           screen          int in value
200         param           name            int in value
201         glxflags        client-handcode server-handcode
202         category        glx
203         dlflags         notlistable
204         glxopcode       19
205
206 ClientInfo()
207         return          void
208         glxflags        client-handcode server-handcode
209         category        glx
210         dlflags         notlistable
211         glxopcode       20
212
213 ###############################################################################
214 #
215 # GLX1.3 commands
216 #
217 ###############################################################################
218 GetFBConfigs(dpy, screen, nelements)
219         return          GLXFBConfigPointer
220         param           dpy             DisplayPointer in value
221         param           screen          int in value
222         param           nelements       int out reference
223         category        glx
224         dlflags         notlistable
225         glxflags        client-handcode server-handcode
226         glxopcode       21
227
228 CreatePixmap(dpy, config, pixmap, attriblist)
229         return          GLXPixmap
230         param           dpy             DisplayPointer in value
231         param           config          GLXFBConfig in value
232         param           pixmap          Pixmap in value
233         param           attriblist      int in array
234         dlflags         notlistable
235         glxflags        client-handcode server-handcode
236         category        glx
237         glxopcode       22
238
239 DestroyPixmap(dpy, pixmap)
240         return          void
241         param           dpy             DisplayPointer in value
242         param           pixmap          Pixmap in value
243         dlflags         notlistable
244         glxflags        client-handcode server-handcode
245         category        glx
246         glxopcode       23
247
248 CreateNewContext(dpy, config, render_type, share_list, direct)
249         return          GLXContext
250         param           dpy             DisplayPointer in value
251         param           config          GLXFBConfig in value
252         param           render_type     int in value
253         param           share_list      GLXContext in value
254         param           direct          Bool in value
255         dlflags         notlistable
256         glxflags        client-handcode server-handcode
257         category        glx
258         glxopcode       24
259
260 QueryContext(dpy, context, attribute, value)
261         return          int
262         param           dpy             DisplayPointer in value
263         param           context         GLXContext in value
264         param           attribute       int in value
265         param           value           int out reference
266         dlflags         notlistable
267         glxflags        client-handcode server-handcode
268         category        glx
269         glxopcode       25
270
271 MakeContextCurrent(dpy, drawdrawable, readdrawable, context)
272         return          Bool
273         param           dpy             DisplayPointer in value
274         param           drawdrawable    GLXDrawable in value
275         param           readdrawable    GLXDrawable in value
276         param           context         GLXContext in value
277         dlflags         notlistable
278         glxflags        client-handcode server-handcode
279         category        glx
280         glxopcode       26
281
282 CreatePbuffer(dpy, config, attrib_list)
283         return          GLXPbuffer
284         param           dpy             DisplayPointer in value
285         param           config          GLXFBConfig in value
286         param           attrib_list     int in array
287         dlflags         notlistable
288         glxflags        client-handcode server-handcode
289         category        glx
290         glxopcode       27
291
292 DestroyPbuffer(dpy, pbuffer)
293         return          void
294         param           dpy             DisplayPointer in value
295         param           pbuffer         GLXPbuffer in value
296         dlflags         notlistable
297         glxflags        client-handcode
298         category        glx
299         glxopcode       28
300
301 GetDrawableAttributes(drawable)
302         return          void
303         param           drawable        int in value
304         dlflags         notlistable
305         glxflags        client-handcode server-handcode
306         category        glx
307         glxopcode       29
308
309 ChangeDrawableAttributes(drawable)
310         return          void
311         param           drawable        int in value
312         dlflags         notlistable
313         glxflags        client-handcode server-handcode
314         category        glx
315         glxopcode       30
316
317 CreateWindow(dpy, config, window, attrib_list)
318         return          GLXWindow
319         param           dpy             DisplayPointer in value
320         param           config          GLXFBConfig in value
321         param           window          Window in value
322         param           attrib_list     int in array
323         dlflags         notlistable
324         glxflags        client-handcode server-handcode
325         category        glx
326         glxopcode       31
327
328 DestroyWindow(dpy, window)
329         return          void
330         param           dpy             DisplayPointer in value
331         param           window          Window in value
332         dlflags         notlistable
333         glxflags        client-handcode server-handcode
334         category        glx
335         glxopcode       32
336
337 ChooseVisual(dpy, screen, attriblist)
338         return          XVisualInfoPointer
339         param           dpy             DisplayPointer in value
340         param           screen          int in value
341         param           attriblist      int out array
342         category        glx
343
344 ###############################################################################
345 #
346 # IRIX5.3 extension commands
347 #
348 ###############################################################################
349
350 ###############################################################################
351 #
352 # SGI_swap_control extension commands
353 #
354 ###############################################################################
355 SwapIntervalSGI()
356         return          void
357         glxflags        client-handcode server-handcode
358         category        glx
359         dlflags         notlistable
360         glxvendorglx    65536
361
362 ###############################################################################
363 #
364 # IRIX5.3-PATCH154 extension commands
365 #
366 ###############################################################################
367
368 ###############################################################################
369 #
370 # SGI_make_current_read extension commands
371 #
372 ###############################################################################
373 MakeCurrentReadSGI(drawable, readdrawable, context)
374         return          void
375         param           drawable        Int32 in value
376         param           readdrawable    Int32 in value
377         param           context         Int32 in value
378         glxflags        client-handcode server-handcode
379         category        glx
380         dlflags         notlistable
381         glxvendorglx    65537
382
383 ###############################################################################
384 #
385 # SGIX_video_source extension commands
386 #
387 ###############################################################################
388 CreateGLXVideoSourceSGIX(dpy, screen, server, path, class, node)
389         return          void
390         param           dpy                     Int32 in value
391         param           screen                  Int32 in value
392         param           server                  Int32 in value
393         param           path                    Int32 in value
394         param           class                   Int32 in value
395         param           node                    Int32 in value
396         glxflags        client-handcode server-handcode
397         category        glx
398         dlflags         notlistable
399         glxvendorglx    65538
400
401 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
402         return          void
403         param           dpy                     Int32 in value
404         param           glxvideosource          Int32 in value
405         glxflags        client-handcode server-handcode
406         category        glx
407         dlflags         notlistable
408         glxvendorglx    65539
409
410 ###############################################################################
411 #
412 # IRIX6.2 extension commands
413 #
414 ###############################################################################
415
416 ###############################################################################
417 #
418 # EXT_import_context extension commands
419 #
420 ###############################################################################
421 QueryContextInfoEXT(dpy, context, attribute, value)
422         return           Int32
423         param           dpy             DisplayPointer in value
424         param           context         GLXContext in value
425         param           attribute       Int32 in value
426         param           value           Int32 out reference
427         category         glx
428         dlflags          notlistable
429         glxflags         client-handcode server-handcode
430         glxvendorglx     1024
431
432 ###############################################################################
433 #
434 # SGIX_fbconfig extension commands
435 #
436 ###############################################################################
437 GetFBConfigsSGIX()
438         return           void
439         category         glx
440         dlflags          notlistable
441         glxflags         client-handcode server-handcode
442         glxvendorglx     65540
443
444 CreateContextWithConfigSGIX(dpy, config, renderType, share_list, allow_direct)
445         return           GLXContext
446         param            dpy            DisplayPointer in value
447         param            config         GLXFBConfigSGIX in value
448         param            renderType     Int32 in value
449         param            share_list     GLXContext in value
450         param            allow_direct   Bool in value
451         glxflags         client-handcode server-handcode
452         category         glx
453         dlflags          notlistable
454         glxvendorglx     65541
455
456 CreateGLXPixmapWithConfigSGIX(dpy, config, pixmap, attriblist)
457         return          GLXPixmap
458         param           dpy             DisplayPointer in value
459         param           config          GLXFBConfigSGIX in value
460         param           pixmap          Pixmap in value
461         param           attriblist      Int32 in array
462         category        glx
463         dlflags         notlistable
464         glxflags        client-handcode server-handcode
465         glxvendorglx    65542
466
467 ###############################################################################
468 #
469 # SGIX_pbuffer extension commands
470 #
471 ###############################################################################
472
473 CreateGLXPbufferSGIX(dpy, config, width, height, attriblist)
474         return           GLXPbuffer
475         param            dpy            DisplayPointer in value
476         param            config         GLXFBConfig in value
477         param            width          UInt32 in value
478         param            height         UInt32 in value
479         param            attriblist     Int32 in array
480         dlflags          notlistable
481         glxflags         client-handcode server-handcode
482         category         glx
483         glxvendorglx     65543
484
485 DestroyGLXPbufferSGIX(dpy, pbuffer)
486         return           void
487         param            dpy            DisplayPointer in value
488         param            pbuffer        GLXPbuffer in value
489         dlflags          notlistable
490         glxflags         client-handcode
491         category         glx
492         glxvendorglx     65544
493
494 ChangeDrawableAttributesSGIX(drawable)
495         return           void
496         param            drawable       Int32 in value
497         dlflags          notlistable
498         glxflags         client-handcode server-handcode
499         category         glx
500         glxvendorglx     65545
501
502 GetDrawableAttributesSGIX(drawable)
503         return           void
504         param            drawable       Int32 in value
505         dlflags          notlistable
506         glxflags         client-handcode server-handcode
507         category         glx
508         glxvendorglx     65546
509
510 ###############################################################################
511 #
512 # SGIX_swap_group extension commands
513 #
514 ###############################################################################
515
516 JoinSwapGroupSGIX(dpy, drawable, member)
517         return          void
518         param           dpy             DisplayPointer in value
519         param           drawable        GLXDrawable in value
520         param           member          GLXDrawable in value
521         glxflags        client-handcode server-handcode
522         category        glx
523         dlflags         notlistable
524         glxvendorglx    65547
525
526 ###############################################################################
527 #
528 # SGIX_swap_barrier extension commands
529 #
530 ###############################################################################
531
532 BindSwapBarrierSGIX(dpy, drawable, barrier)
533         return          void
534         param           dpy             DisplayPointer in value
535         param           drawable        GLXDrawable in value
536         param           barrier         Int32 in value
537         glxflags        client-handcode server-handcode
538         category        glx
539         dlflags         notlistable
540         glxvendorglx    65548
541
542 QueryMaxSwapBarriersSGIX(dpy, screen, max)
543         return          Bool
544         param           dpy             DisplayPointer in value
545         param           screen          Int32 in value
546         param           max             Int32 out value
547         glxflags        client-handcode server-handcode
548         category        glx
549         dlflags         notlistable
550         glxvendorglx    65549
551
552 ###############################################################################
553 #
554 # SGIX_hyperpipe extension commands
555 #
556 ###############################################################################
557
558 QueryHyperpipeNetworkSGIX(dpy, npipes)
559         return          GLXHyperpipeNetworkPointer
560         param           dpy             Display out reference
561         param           npipes          int out reference
562         glxflags        client-handcode server-handcode
563         category        glx
564         dlflags         notlistable
565         glxvendorglx    65550
566
567 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
568         return          int
569         param           dpy             Display out reference
570         param           networkId       int in value
571         param           npipes          int in value
572         param           cfg             GLXHyperpipeConfig in array[npipes]
573         param           hpId            int out reference
574         glxflags        client-handcode server-handcode
575         category        glx
576         dlflags         notlistable
577         glxvendorglx    65552
578
579 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
580         return          GLXHyperpipeConfigPointer
581         param           dpy             Display out reference
582         param           hpId            int in value
583         param           npipes          int out reference
584         glxflags        client-handcode server-handcode
585         category        glx
586         dlflags         notlistable
587         glxvendorglx    65551
588
589 DestroyHyperpipeConfigSGIX(dpy, hpId)
590         return          int
591         param           dpy             Display out reference
592         param           hpId            int in value
593         glxflags        client-handcode server-handcode
594         category        glx
595         dlflags         notlistable
596         glxvendorglx    65553
597
598 BindHyperpipeSGIX(dpy, hpId)
599         return          int
600         param           dpy             Display out reference
601         param           hpId            int in value
602         glxflags        client-handcode server-handcode
603         category        glx
604         dlflags         notlistable
605         glxvendorglx    ???
606
607 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
608         return          int
609         param           dpy             Display out reference
610         param           timeSlice       int in value
611         param           attrib          int in value
612         param           size            int in value
613         param           attribList      Void in array[size]
614         param           returnAttribList Void out array[size]
615         glxflags        client-handcode server-handcode
616         category        glx
617         dlflags         notlistable
618         glxvendorglx    ???
619
620 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
621         return          int
622         param           dpy             Display out reference
623         param           timeSlice       int in value
624         param           attrib          int in value
625         param           size            int in value
626         param           attribList      void in array[size]
627         glxflags        client-handcode server-handcode
628         category        glx
629         dlflags         notlistable
630         glxvendorglx    ???
631
632 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
633         return          int
634         param           dpy             Display out reference
635         param           timeSlice       int in value
636         param           attrib          int in value
637         param           size            int in value
638         param           returnAttribList void in array[size]
639         glxflags        client-handcode server-handcode
640         category        glx
641         dlflags         notlistable
642         glxvendorglx    ???