]> git.tdb.fi Git - gldbg.git/blob - flavors/gl/glx.spec
Add some missing glX functions
[gldbg.git] / flavors / gl / glx.spec
1 # Copyright (C) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
2 #
3 # This document is licensed under the SGI Free Software B License Version
4 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
5
6 required-props:
7 param:          retval retained
8 dlflags:        notlistable handcode nop
9 glxflags:       client-handcode server-handcode
10 glxvendorglx:   *
11 vectorequiv:    *
12 category:       pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
13 glxopcode:              *
14
15 QueryExtension(dpy, errorb, event)
16         return          Bool
17         param           dpy     DisplayPointer in value
18         param           errorb  int out reference
19         param           event   int out reference
20
21 GetCurrentContext()
22         return          GLXContext
23
24 GetCurrentDrawable()
25         return          GLXDrawable
26
27 GetClientString(dpy, name)
28         return          GLXstring
29         param           dpy     DisplayPointer in value
30         param           name    int in value
31 ###############################################################################
32 #
33 # GLX1.0 commands
34 #
35 ###############################################################################
36 Render()
37         return           void
38         category         glx
39         dlflags          notlistable
40         glxflags         client-handcode server-handcode
41         glxopcode        1
42
43
44 RenderLarge()
45         return           void
46         category         glx
47         dlflags          notlistable
48         glxflags         client-handcode server-handcode
49         glxopcode        2
50
51
52 CreateContext(dpy, visual, share_list, direct)
53         return           GLXContext
54         param            dpy            DisplayPointer in value
55         param            visual         XVisualInfoPointer in value
56         param            share_list     GLXContext in value
57         param            direct         Bool in value
58         glxflags         client-handcode server-handcode
59         category         glx
60         dlflags          notlistable
61         glxopcode        3
62
63
64 DestroyContext(dpy, ctx)
65         return           void
66         param            dpy            DisplayPointer in value
67         param            ctx            GLXContext in value
68         glxflags         client-handcode server-handcode
69         category         glx
70         dlflags          notlistable
71         glxopcode        4
72
73
74 MakeCurrent(dpy, drawable, ctx)
75         return           Bool
76         param            dpy            DisplayPointer in value
77         param            drawable       GLXDrawable in value
78         param            ctx            GLXContext in value
79         category         glx
80         dlflags          notlistable
81         glxopcode        5
82
83
84 IsDirect(dpy, ctx)
85         return           Bool
86         param            dpy            DisplayPointer in value
87         param            ctx            GLXContext in value
88         glxflags         client-handcode server-handcode
89         category         glx
90         dlflags          notlistable
91         glxopcode        6
92
93
94 QueryVersion(dpy, major, minor)
95         return           Bool
96         param            dpy            DisplayPointer in value
97         param            major          int out reference
98         param            minor          int out reference
99         category         glx
100         dlflags          notlistable
101         glxflags         client-handcode server-handcode
102         glxopcode        7
103
104
105 WaitGL()
106         return           void
107         category         glx
108         dlflags          notlistable
109         glxflags         client-handcode server-handcode
110         glxopcode        8
111
112
113 WaitX()
114         return           void
115         category         glx
116         dlflags          notlistable
117         glxflags         client-handcode server-handcode
118         glxopcode        9
119
120
121 CopyContext(dpy, source, dest, mask)
122         return           void
123         param            dpy            DisplayPointer in value
124         param            source         GLXContext in value
125         param            dest           GLXContext in value
126         param            mask           ulong in value
127         category         glx
128         dlflags          notlistable
129         glxflags         client-handcode server-handcode
130         glxopcode        10
131
132
133 SwapBuffers(dpy, drawable)
134         return           void
135         param            dpy            DisplayPointer in value
136         param            drawable       GLXDrawable in value
137         category         glx
138         dlflags          notlistable
139         glxflags         client-handcode server-handcode
140         glxopcode        11
141
142
143 UseXFont(font, first, count, list_base)
144         return           void
145         param            font           Font in value
146         param            first          int in value
147         param            count          int in value
148         param            list_base      int in value
149         category         glx
150         dlflags          notlistable
151         glxflags         client-handcode server-handcode
152         glxopcode        12
153
154
155 CreateGLXPixmap(dpy, visual, pixmap)
156         return           GLXPixmap
157         param            dpy            DisplayPointer in value
158         param            visual         XVisualInfoPointer in value
159         param            pixmap         Pixmap in value
160         category         glx
161         dlflags          notlistable
162         glxflags         client-handcode server-handcode
163         glxopcode        13
164
165 GetVisualConfigs()
166         return           void
167         category         glx
168         dlflags          notlistable
169         glxflags         client-handcode server-handcode
170         glxopcode        14
171
172
173 GetConfig(dpy, visual, attribute, value)
174         return           int
175         param            dpy            DisplayPointer in value
176         param            visual XVisualInfoPointer in value
177         param            attribute      int in value
178         param            value          int out reference
179
180
181 DestroyGLXPixmap(dpy, pixmap)
182         return           void
183         param            dpy            DisplayPointer in value
184         param            pixmap         GLXPixmap in value
185         glxflags         client-handcode
186         category         glx
187         dlflags          notlistable
188         glxopcode        15
189
190
191 VendorPrivate()
192         return          void
193         glxflags        client-handcode server-handcode
194         category        glx
195         dlflags         notlistable
196         glxopcode       16
197
198
199 VendorPrivateWithReply()
200         return          void
201         glxflags        client-handcode server-handcode
202         category        glx
203         dlflags         notlistable
204         glxopcode       17
205
206 ###############################################################################
207 #
208 # GLX1.1 commands
209 #
210 ###############################################################################
211 QueryExtensionsString(dpy, screen)
212         return          GLXstring
213         param           dpy             DisplayPointer in value
214         param           screen          int in value
215         glxflags        client-handcode server-handcode
216         category        glx
217         dlflags         notlistable
218         glxopcode       18
219
220 QueryServerString(dpy, screen, name)
221         return          GLXstring
222         param           dpy             DisplayPointer in value
223         param           screen          int in value
224         param           name            int in value
225         glxflags        client-handcode server-handcode
226         category        glx
227         dlflags         notlistable
228         glxopcode       19
229
230 ClientInfo()
231         return          void
232         glxflags        client-handcode server-handcode
233         category        glx
234         dlflags         notlistable
235         glxopcode       20
236
237 ###############################################################################
238 #
239 # GLX1.3 commands
240 #
241 ###############################################################################
242 GetFBConfigs(dpy, screen, nelements)
243         return          GLXFBConfigPointer
244         param           dpy             DisplayPointer in value
245         param           screen          int in value
246         param           nelements       int out reference
247         category        glx
248         dlflags         notlistable
249         glxflags        client-handcode server-handcode
250         glxopcode       21
251
252 CreatePixmap(dpy, config, pixmap, attriblist)
253         return          GLXPixmap
254         param           dpy             DisplayPointer in value
255         param           config          GLXFBConfig in value
256         param           pixmap          Pixmap in value
257         param           attriblist      int in array
258         dlflags         notlistable
259         glxflags        client-handcode server-handcode
260         category        glx
261         glxopcode       22
262
263 DestroyPixmap(dpy, pixmap)
264         return          void
265         param           dpy             DisplayPointer in value
266         param           pixmap          Pixmap in value
267         dlflags         notlistable
268         glxflags        client-handcode server-handcode
269         category        glx
270         glxopcode       23
271
272 CreateNewContext(dpy, config, render_type, share_list, direct)
273         return          GLXContext
274         param           dpy             DisplayPointer in value
275         param           config          GLXFBConfig in value
276         param           render_type     int in value
277         param           share_list      GLXContext in value
278         param           direct          Bool in value
279         dlflags         notlistable
280         glxflags        client-handcode server-handcode
281         category        glx
282         glxopcode       24
283
284 QueryContext(dpy, context, attribute, value)
285         return          int
286         param           dpy             DisplayPointer in value
287         param           context         GLXContext in value
288         param           attribute       int in value
289         param           value           int out reference
290         dlflags         notlistable
291         glxflags        client-handcode server-handcode
292         category        glx
293         glxopcode       25
294
295 MakeContextCurrent(dpy, drawdrawable, readdrawable, context)
296         return          Bool
297         param           dpy             DisplayPointer in value
298         param           drawdrawable    GLXDrawable in value
299         param           readdrawable    GLXDrawable in value
300         param           context         GLXContext in value
301         dlflags         notlistable
302         glxflags        client-handcode server-handcode
303         category        glx
304         glxopcode       26
305
306 CreatePbuffer(dpy, config, attrib_list)
307         return          GLXPbuffer
308         param           dpy             DisplayPointer in value
309         param           config          GLXFBConfig in value
310         param           attrib_list     int in array
311         dlflags         notlistable
312         glxflags        client-handcode server-handcode
313         category        glx
314         glxopcode       27
315
316 DestroyPbuffer(dpy, pbuffer)
317         return          void
318         param           dpy             DisplayPointer in value
319         param           pbuffer         GLXPbuffer in value
320         dlflags         notlistable
321         glxflags        client-handcode
322         category        glx
323         glxopcode       28
324
325 GetDrawableAttributes(drawable)
326         return          void
327         param           drawable        int in value
328         dlflags         notlistable
329         glxflags        client-handcode server-handcode
330         category        glx
331         glxopcode       29
332
333 ChangeDrawableAttributes(drawable)
334         return          void
335         param           drawable        int in value
336         dlflags         notlistable
337         glxflags        client-handcode server-handcode
338         category        glx
339         glxopcode       30
340
341 CreateWindow(dpy, config, window, attrib_list)
342         return          GLXWindow
343         param           dpy             DisplayPointer in value
344         param           config          GLXFBConfig in value
345         param           window          Window in value
346         param           attrib_list     int in array
347         dlflags         notlistable
348         glxflags        client-handcode server-handcode
349         category        glx
350         glxopcode       31
351
352 DestroyWindow(dpy, window)
353         return          void
354         param           dpy             DisplayPointer in value
355         param           window          Window in value
356         dlflags         notlistable
357         glxflags        client-handcode server-handcode
358         category        glx
359         glxopcode       32
360
361 ChooseVisual(dpy, screen, attriblist)
362         return          XVisualInfoPointer
363         param           dpy             DisplayPointer in value
364         param           screen          int in value
365         param           attriblist      int out array
366         category        glx
367
368 ###############################################################################
369 #
370 # IRIX5.3 extension commands
371 #
372 ###############################################################################
373
374 ###############################################################################
375 #
376 # SGI_swap_control extension commands
377 #
378 ###############################################################################
379 SwapIntervalSGI()
380         return          void
381         glxflags        client-handcode server-handcode
382         category        glx
383         dlflags         notlistable
384         glxvendorglx    65536
385
386 ###############################################################################
387 #
388 # IRIX5.3-PATCH154 extension commands
389 #
390 ###############################################################################
391
392 ###############################################################################
393 #
394 # SGI_make_current_read extension commands
395 #
396 ###############################################################################
397 MakeCurrentReadSGI(drawable, readdrawable, context)
398         return          void
399         param           drawable        Int32 in value
400         param           readdrawable    Int32 in value
401         param           context         Int32 in value
402         glxflags        client-handcode server-handcode
403         category        glx
404         dlflags         notlistable
405         glxvendorglx    65537
406
407 ###############################################################################
408 #
409 # SGIX_video_source extension commands
410 #
411 ###############################################################################
412 CreateGLXVideoSourceSGIX(dpy, screen, server, path, class, node)
413         return          void
414         param           dpy                     Int32 in value
415         param           screen                  Int32 in value
416         param           server                  Int32 in value
417         param           path                    Int32 in value
418         param           class                   Int32 in value
419         param           node                    Int32 in value
420         glxflags        client-handcode server-handcode
421         category        glx
422         dlflags         notlistable
423         glxvendorglx    65538
424
425 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
426         return          void
427         param           dpy                     Int32 in value
428         param           glxvideosource          Int32 in value
429         glxflags        client-handcode server-handcode
430         category        glx
431         dlflags         notlistable
432         glxvendorglx    65539
433
434 ###############################################################################
435 #
436 # IRIX6.2 extension commands
437 #
438 ###############################################################################
439
440 ###############################################################################
441 #
442 # EXT_import_context extension commands
443 #
444 ###############################################################################
445 QueryContextInfoEXT(dpy, context, attribute, value)
446         return           Int32
447         param           dpy             DisplayPointer in value
448         param           context         GLXContext in value
449         param           attribute       Int32 in value
450         param           value           Int32 out reference
451         category         glx
452         dlflags          notlistable
453         glxflags         client-handcode server-handcode
454         glxvendorglx     1024
455
456 ###############################################################################
457 #
458 # SGIX_fbconfig extension commands
459 #
460 ###############################################################################
461 GetFBConfigsSGIX()
462         return           void
463         category         glx
464         dlflags          notlistable
465         glxflags         client-handcode server-handcode
466         glxvendorglx     65540
467
468 CreateContextWithConfigSGIX(dpy, config, renderType, share_list, allow_direct)
469         return           GLXContext
470         param            dpy            DisplayPointer in value
471         param            config         GLXFBConfigSGIX in value
472         param            renderType     Int32 in value
473         param            share_list     GLXContext in value
474         param            allow_direct   Bool in value
475         glxflags         client-handcode server-handcode
476         category         glx
477         dlflags          notlistable
478         glxvendorglx     65541
479
480 CreateGLXPixmapWithConfigSGIX(dpy, config, pixmap, attriblist)
481         return          GLXPixmap
482         param           dpy             DisplayPointer in value
483         param           config          GLXFBConfigSGIX in value
484         param           pixmap          Pixmap in value
485         param           attriblist      Int32 in array
486         category        glx
487         dlflags         notlistable
488         glxflags        client-handcode server-handcode
489         glxvendorglx    65542
490
491 ###############################################################################
492 #
493 # SGIX_pbuffer extension commands
494 #
495 ###############################################################################
496
497 CreateGLXPbufferSGIX(dpy, config, width, height, attriblist)
498         return           GLXPbuffer
499         param            dpy            DisplayPointer in value
500         param            config         GLXFBConfig in value
501         param            width          UInt32 in value
502         param            height         UInt32 in value
503         param            attriblist     Int32 in array
504         dlflags          notlistable
505         glxflags         client-handcode server-handcode
506         category         glx
507         glxvendorglx     65543
508
509 DestroyGLXPbufferSGIX(dpy, pbuffer)
510         return           void
511         param            dpy            DisplayPointer in value
512         param            pbuffer        GLXPbuffer in value
513         dlflags          notlistable
514         glxflags         client-handcode
515         category         glx
516         glxvendorglx     65544
517
518 ChangeDrawableAttributesSGIX(drawable)
519         return           void
520         param            drawable       Int32 in value
521         dlflags          notlistable
522         glxflags         client-handcode server-handcode
523         category         glx
524         glxvendorglx     65545
525
526 GetDrawableAttributesSGIX(drawable)
527         return           void
528         param            drawable       Int32 in value
529         dlflags          notlistable
530         glxflags         client-handcode server-handcode
531         category         glx
532         glxvendorglx     65546
533
534 ###############################################################################
535 #
536 # SGIX_swap_group extension commands
537 #
538 ###############################################################################
539
540 JoinSwapGroupSGIX(dpy, drawable, member)
541         return          void
542         param           dpy             DisplayPointer in value
543         param           drawable        GLXDrawable in value
544         param           member          GLXDrawable in value
545         glxflags        client-handcode server-handcode
546         category        glx
547         dlflags         notlistable
548         glxvendorglx    65547
549
550 ###############################################################################
551 #
552 # SGIX_swap_barrier extension commands
553 #
554 ###############################################################################
555
556 BindSwapBarrierSGIX(dpy, drawable, barrier)
557         return          void
558         param           dpy             DisplayPointer in value
559         param           drawable        GLXDrawable in value
560         param           barrier         Int32 in value
561         glxflags        client-handcode server-handcode
562         category        glx
563         dlflags         notlistable
564         glxvendorglx    65548
565
566 QueryMaxSwapBarriersSGIX(dpy, screen, max)
567         return          Bool
568         param           dpy             DisplayPointer in value
569         param           screen          Int32 in value
570         param           max             Int32 out value
571         glxflags        client-handcode server-handcode
572         category        glx
573         dlflags         notlistable
574         glxvendorglx    65549
575
576 ###############################################################################
577 #
578 # SGIX_hyperpipe extension commands
579 #
580 ###############################################################################
581
582 QueryHyperpipeNetworkSGIX(dpy, npipes)
583         return          GLXHyperpipeNetworkPointer
584         param           dpy             Display out reference
585         param           npipes          int out reference
586         glxflags        client-handcode server-handcode
587         category        glx
588         dlflags         notlistable
589         glxvendorglx    65550
590
591 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
592         return          int
593         param           dpy             Display out reference
594         param           networkId       int in value
595         param           npipes          int in value
596         param           cfg             GLXHyperpipeConfig in array[npipes]
597         param           hpId            int out reference
598         glxflags        client-handcode server-handcode
599         category        glx
600         dlflags         notlistable
601         glxvendorglx    65552
602
603 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
604         return          GLXHyperpipeConfigPointer
605         param           dpy             Display out reference
606         param           hpId            int in value
607         param           npipes          int out reference
608         glxflags        client-handcode server-handcode
609         category        glx
610         dlflags         notlistable
611         glxvendorglx    65551
612
613 DestroyHyperpipeConfigSGIX(dpy, hpId)
614         return          int
615         param           dpy             Display out reference
616         param           hpId            int in value
617         glxflags        client-handcode server-handcode
618         category        glx
619         dlflags         notlistable
620         glxvendorglx    65553
621
622 BindHyperpipeSGIX(dpy, hpId)
623         return          int
624         param           dpy             Display out reference
625         param           hpId            int in value
626         glxflags        client-handcode server-handcode
627         category        glx
628         dlflags         notlistable
629         glxvendorglx    ???
630
631 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
632         return          int
633         param           dpy             Display out reference
634         param           timeSlice       int in value
635         param           attrib          int in value
636         param           size            int in value
637         param           attribList      Void in array[size]
638         param           returnAttribList Void out array[size]
639         glxflags        client-handcode server-handcode
640         category        glx
641         dlflags         notlistable
642         glxvendorglx    ???
643
644 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
645         return          int
646         param           dpy             Display out reference
647         param           timeSlice       int in value
648         param           attrib          int in value
649         param           size            int in value
650         param           attribList      void in array[size]
651         glxflags        client-handcode server-handcode
652         category        glx
653         dlflags         notlistable
654         glxvendorglx    ???
655
656 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
657         return          int
658         param           dpy             Display out reference
659         param           timeSlice       int in value
660         param           attrib          int in value
661         param           size            int in value
662         param           returnAttribList void in array[size]
663         glxflags        client-handcode server-handcode
664         category        glx
665         dlflags         notlistable
666         glxvendorglx    ???