Require import module names to be identifiers
[libs/gl.git] / gl.msp.xml
index cea6395bf9d5238a73464bd1acfb1e08682d37c4..a1787cb02f124fb3dbf0a1a2752f5025bbf43d0c 100644 (file)
@@ -67,7 +67,7 @@
         </extension>
 
         <!-- OpenGL ES does not have glDrawBuffer. -->
-        <extension name="GL_MSP_draw_buffer" supported="gl">
+        <extension name="GL_MSP_buffer_control" supported="gl">
             <require>
                 <command name="glDrawBuffer" />
                 <command name="glReadBuffer" />
             </require>
         </extension>
 
-        <!-- Stereo rendering is not supported on OpenGL ES, but I'm not
-        certain enough of its uselessness to remove the constants outright. -->
-        <extension name="GL_MSP_stereo_rendering" supported="gl">
-            <require>
-                <enum name="GL_FRONT_LEFT" />
-                <enum name="GL_FRONT_RIGHT" />
-                <enum name="GL_BACK_LEFT" />
-                <enum name="GL_BACK_RIGHT" />
-                <enum name="GL_LEFT" />
-                <enum name="GL_RIGHT" />
-            </require>
-        </extension>
-
-        <!-- Sized internal formats were introduced in OpenGL ES 3.0, but are
-        not available as an extension. -->
-        <extension name="GL_MSP_sized_internal_formats" supported="gl|gles2">
-            <require>
-                <enum name="GL_RGB8" />
-                <enum name="GL_RGBA8" />
-            </require>
-        </extension>
-
         <!-- 1D textures are not available in OpenGL ES, but could conceivably
         be added at a later date. -->
         <extension name="GL_MSP_texture1D" supported="gl">