2 # DON'T REMOVE PREVIOUS LINE!!! libspec depends on it!
4 # Copyright (C) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
6 # This document is licensed under the SGI Free Software B License Version
7 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
10 param: retval retained
11 glxflags: client-handcode client-intercept server-handcode
14 category: VERSION_1_3 VERSION_1_4 ARB_get_proc_address ARB_multisample ARB_fbconfig_float EXT_import_context SGIX_dmbuffer SGIX_fbconfig SGIX_pbuffer SGIX_swap_barrier SGIX_swap_group SGIX_video_resize SGIX_video_source SGI_cushion SGI_make_current_read SGI_swap_control SGI_video_sync SUN_get_transparent_index MESA_agp_offset MESA_copy_sub_buffer MESA_pixmap_colormap MESA_release_buffers MESA_set_3dfx_mode SGIX_visual_select_group OML_sync_control SGIX_hyperpipe EXT_texture_from_pixmap NV_swap_group NV_video_output NV_present_video ARB_create_context NV_video_capture NV_copy_image
18 # Boilerplate to define types used by some extensions. This is done
19 # up front, since it involves some complexities in protecting
20 # the declarations whether or not the -protect flag is given to
21 # the generator scripts.
24 passthru: #ifndef GLX_ARB_get_proc_address
25 passthru: typedef void (*__GLXextFuncPtr)(void);
28 passthru: #ifndef GLX_SGIX_video_source
29 passthru: typedef XID GLXVideoSourceSGIX;
32 passthru: #ifndef GLX_SGIX_fbconfig
33 passthru: typedef XID GLXFBConfigIDSGIX;
34 passthru: typedef struct __GLXFBConfigRec *GLXFBConfigSGIX;
37 passthru: #ifndef GLX_SGIX_pbuffer
38 passthru: typedef XID GLXPbufferSGIX;
39 passthru: typedef struct {
41 passthru: unsigned long serial; /* # of last request processed by server */
42 passthru: Bool send_event; /* true if this came for SendEvent request */
43 passthru: Display *display; /* display the event was read from */
44 passthru: GLXDrawable drawable; /* i.d. of Drawable */
45 passthru: int event_type; /* GLX_DAMAGED_SGIX or GLX_SAVED_SGIX */
46 passthru: int draw_type; /* GLX_WINDOW_SGIX or GLX_PBUFFER_SGIX */
47 passthru: unsigned int mask; /* mask indicating which buffers are affected*/
49 passthru: int width, height;
50 passthru: int count; /* if nonzero, at least this many more */
51 passthru: } GLXBufferClobberEventSGIX;
54 passthru: /* The next two typedefs are placeholders until NVIDIA clarifies these types */
55 passthru: #ifndef GLX_NV_video_output
56 passthru: typedef struct { unsigned int dummy; } *GLXVideoDeviceNV;
59 passthru: #ifndef GLX_NV_video_capture
60 passthru: typedef struct { unsigned int dummy; } *GLXVideoCaptureDeviceNV;
63 passthru: #ifndef GLEXT_64_TYPES_DEFINED
64 passthru: /* This code block is duplicated in glext.h, so must be protected */
65 passthru: #define GLEXT_64_TYPES_DEFINED
66 passthru: /* Define int32_t, int64_t, and uint64_t types for UST/MSC */
67 passthru: /* (as used in the GLX_OML_sync_control extension). */
68 passthru: #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
69 passthru: #include <inttypes.h>
70 passthru: #elif defined(__sun__) || defined(__digital__)
71 passthru: #include <inttypes.h>
72 passthru: #if defined(__STDC__)
73 passthru: #if defined(__arch64__) || defined(_LP64)
74 passthru: typedef long int int64_t;
75 passthru: typedef unsigned long int uint64_t;
77 passthru: typedef long long int int64_t;
78 passthru: typedef unsigned long long int uint64_t;
79 passthru: #endif /* __arch64__ */
80 passthru: #endif /* __STDC__ */
81 passthru: #elif defined( __VMS ) || defined(__sgi)
82 passthru: #include <inttypes.h>
83 passthru: #elif defined(__SCO__) || defined(__USLC__)
84 passthru: #include <stdint.h>
85 passthru: #elif defined(__UNIXOS2__) || defined(__SOL64__)
86 passthru: typedef long int int32_t;
87 passthru: typedef long long int int64_t;
88 passthru: typedef unsigned long long int uint64_t;
89 passthru: #elif defined(_WIN32) && defined(__GNUC__)
90 passthru: #include <stdint.h>
91 passthru: #elif defined(_WIN32)
92 passthru: typedef __int32 int32_t;
93 passthru: typedef __int64 int64_t;
94 passthru: typedef unsigned __int64 uint64_t;
96 passthru: #include <inttypes.h> /* Fallback option */
101 ###############################################################################
105 ###############################################################################
107 GetFBConfigs(dpy, screen, nelements)
108 return GLXFBConfigPointer
109 param dpy Display out reference
110 param screen int in value
111 param nelements int out reference
113 glxflags client-handcode server-handcode
116 ChooseFBConfig(dpy, screen, attrib_list, nelements)
117 return GLXFBConfigPointer
118 param dpy Display out reference
119 param screen int in value
120 param attrib_list int in reference
121 param nelements int out reference
123 glxflags client-handcode client-intercept server-handcode
125 GetFBConfigAttrib(dpy, config, attribute, value)
127 param dpy Display out reference
128 param config GLXFBConfig in value
129 param attribute int in value
130 param value int out reference
132 glxflags client-handcode client-intercept server-handcode
134 GetVisualFromFBConfig(dpy, config)
135 return XVisualInfoPointer
136 param dpy Display out reference
137 param config GLXFBConfig in value
139 glxflags client-handcode client-intercept server-handcode
141 CreateWindow(dpy, config, win, attrib_list)
143 param dpy Display out reference
144 param config GLXFBConfig in value
145 param win Window in value
146 param attrib_list int in reference
148 glxflags client-handcode server-handcode
151 DestroyWindow(dpy, win)
153 param dpy Display out reference
154 param win GLXWindow in value
156 glxflags client-handcode server-handcode
159 CreatePixmap(dpy, config, pixmap, attrib_list)
161 param dpy Display out reference
162 param config GLXFBConfig in value
163 param pixmap Pixmap in value
164 param attrib_list int in reference
166 glxflags client-handcode server-handcode
169 DestroyPixmap(dpy, pixmap)
171 param dpy Display out reference
172 param pixmap GLXPixmap in value
174 glxflags client-handcode server-handcode
177 CreatePbuffer(dpy, config, attrib_list)
179 param dpy Display out reference
180 param config GLXFBConfig in value
181 param attrib_list int in reference
183 glxflags client-handcode server-handcode
186 DestroyPbuffer(dpy, pbuf)
188 param dpy Display out reference
189 param pbuf GLXPbuffer in value
191 glxflags client-handcode server-handcode
194 # glXGetDrawableAttributes -> GLX opcode 29
195 # glXChangeDrawableAttributes -> GLX opcode 30
197 # Uses glXGetDrawableAttributes protocol
198 QueryDrawable(dpy, draw, attribute, value)
200 param dpy Display out reference
201 param draw GLXDrawable in value
202 param attribute int in value
203 param value uint out reference
205 glxflags client-handcode client-intercept server-handcode
207 CreateNewContext(dpy, config, render_type, share_list, direct)
209 param dpy Display out reference
210 param config GLXFBConfig in value
211 param render_type int in value
212 param share_list GLXContext in value
213 param direct Bool in value
215 glxflags client-handcode server-handcode
218 MakeContextCurrent(dpy, draw, read, ctx)
220 param dpy Display out reference
221 param draw GLXDrawable in value
222 param read GLXDrawable in value
223 param ctx GLXContext in value
225 glxflags client-handcode server-handcode
228 GetCurrentReadDrawable()
231 glxflags client-handcode client-intercept server-handcode
234 return DisplayPointer
236 glxflags client-handcode client-intercept server-handcode
238 QueryContext(dpy, ctx, attribute, value)
240 param dpy Display out reference
241 param ctx GLXContext in value
242 param attribute int in value
243 param value int out reference
245 glxflags client-handcode server-handcode
248 # Uses glXChangeDrawableAttributes protocol
249 SelectEvent(dpy, draw, event_mask)
251 param dpy Display out reference
252 param draw GLXDrawable in value
253 param event_mask ulong in value
255 glxflags client-handcode server-handcode
257 # Uses glXGetDrawableAttributes protocol
258 GetSelectedEvent(dpy, draw, event_mask)
260 param dpy Display out reference
261 param draw GLXDrawable in value
262 param event_mask ulong out reference
264 glxflags client-handcode client-intercept server-handcode
266 ###############################################################################
270 ###############################################################################
272 GetProcAddress(procName)
273 return FunctionPointer
274 param procName GLubyte in reference
276 glxflags client-handcode client-intercept server-handcode
278 ###############################################################################
281 # ARB_get_proc_address commands
282 # @promoted to core in GLX 1.4, but there's no provision for aliasing
283 # @in GLX spec files, yet
285 ###############################################################################
287 GetProcAddressARB(procName)
288 return FunctionPointer
289 param procName GLubyte in reference
290 category ARB_get_proc_address
291 glxflags client-handcode client-intercept server-handcode
293 ###############################################################################
296 # ARB_multisample commands
298 ###############################################################################
301 newcategory: ARB_multisample
303 ###############################################################################
306 # ARB_fbconfig_float commands
308 ###############################################################################
311 newcategory: ARB_fbconfig_float
313 ###############################################################################
316 # ARB_create_context commands
318 ###############################################################################
320 CreateContextAttribsARB(dpy, config, share_context, direct, attrib_list)
322 param dpy Display out reference
323 param config GLXFBConfig in value
324 param share_context GLXContext in value
325 param direct Bool in value
326 param attrib_list int in reference
327 category ARB_create_context
328 glxflags client-handcode client-intercept server-handcode
331 ###############################################################################
334 # ARB_create_context_profile commands
336 ###############################################################################
339 newcategory: ARB_create_context_profile
342 ###############################################################################
345 # SGIS_multisample commands
347 ###############################################################################
350 newcategory: SGIS_multisample
352 ###############################################################################
355 # EXT_visual_info commands
357 ###############################################################################
360 newcategory: EXT_visual_info
362 ###############################################################################
365 # SGI_swap_control commands
367 ###############################################################################
369 SwapIntervalSGI(interval)
371 param interval int in value
372 category SGI_swap_control
373 glxflags client-handcode server-handcode
376 ###############################################################################
379 # SGI_video_sync commands
381 ###############################################################################
383 GetVideoSyncSGI(count)
385 param count uint out reference
386 category SGI_video_sync
387 glxflags client-handcode client-intercept server-handcode
389 WaitVideoSyncSGI(divisor, remainder, count)
391 param divisor int in value
392 param remainder int in value
393 param count uint out reference
394 category SGI_video_sync
395 glxflags client-handcode client-intercept server-handcode
397 ###############################################################################
400 # SGI_make_current_read commands
402 ###############################################################################
404 MakeCurrentReadSGI(dpy, draw, read, ctx)
406 param dpy Display out reference
407 param draw GLXDrawable in value
408 param read GLXDrawable in value
409 param ctx GLXContext in value
410 category SGI_make_current_read
411 glxflags client-handcode server-handcode
414 GetCurrentReadDrawableSGI()
416 category SGI_make_current_read
417 glxflags client-handcode client-intercept server-handcode
419 ###############################################################################
422 # SGIX_video_source commands
424 ###############################################################################
426 newcategory: SGIX_video_source
427 passthru: #ifdef _VL_H
429 CreateGLXVideoSourceSGIX(display, screen, server, path, nodeClass, drainNode)
430 return GLXVideoSourceSGIX
431 param display Display out reference
432 param screen int in value
433 param server VLServer in value
434 param path VLPath in value
435 param nodeClass int in value
436 param drainNode VLNode in value
437 category SGIX_video_source
438 glxflags client-handcode server-handcode
441 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
443 param dpy Display out reference
444 param glxvideosource GLXVideoSourceSGIX in value
445 category SGIX_video_source
446 glxflags client-handcode server-handcode
449 passend: #endif /* _VL_H */
452 ###############################################################################
455 # EXT_visual_rating commands
457 ###############################################################################
460 newcategory: EXT_visual_rating
462 ###############################################################################
465 # EXT_import_context commands
467 ###############################################################################
469 GetCurrentDisplayEXT()
470 return DisplayPointer
471 category EXT_import_context
472 glxflags client-handcode client-intercept server-handcode
474 QueryContextInfoEXT(dpy, context, attribute, value)
476 param dpy Display out reference
477 param context GLXContext in value
478 param attribute int in value
479 param value int out reference
480 category EXT_import_context
481 glxflags client-handcode server-handcode
484 # 'constGLXContext' is a hack; the extension specification and glx.h
485 # should be fixed instead.
486 GetContextIDEXT(context)
488 param context constGLXContext in value
489 category EXT_import_context
490 glxflags client-handcode client-intercept server-handcode
492 ImportContextEXT(dpy, contextID)
494 param dpy Display out reference
495 param contextID GLXContextID in value
496 category EXT_import_context
497 glxflags client-handcode client-intercept server-handcode
499 FreeContextEXT(dpy, context)
501 param dpy Display out reference
502 param context GLXContext in value
503 category EXT_import_context
504 glxflags client-handcode client-intercept server-handcode
506 ###############################################################################
509 # SGIX_fbconfig commands
511 ###############################################################################
513 # GetFBConfigsSGIX protocol -> VendorPrivate opcode 65540
515 GetFBConfigAttribSGIX(dpy, config, attribute, value)
517 param dpy Display out reference
518 param config GLXFBConfigSGIX in value
519 param attribute int in value
520 param value int out reference
521 category SGIX_fbconfig
522 glxflags client-handcode client-intercept server-handcode
524 ChooseFBConfigSGIX(dpy, screen, attrib_list, nelements)
525 return GLXFBConfigSGIXPointer
526 param dpy Display out reference
527 param screen int in value
528 param attrib_list int out reference
529 param nelements int out reference
530 category SGIX_fbconfig
531 glxflags client-handcode client-intercept server-handcode
533 CreateGLXPixmapWithConfigSGIX(dpy, config, pixmap)
535 param dpy Display out reference
536 param config GLXFBConfigSGIX in value
537 param pixmap Pixmap in value
538 category SGIX_fbconfig
539 glxflags client-handcode server-handcode
542 CreateContextWithConfigSGIX(dpy, config, render_type, share_list, direct)
544 param dpy Display out reference
545 param config GLXFBConfigSGIX in value
546 param render_type int in value
547 param share_list GLXContext in value
548 param direct Bool in value
549 category SGIX_fbconfig
550 glxflags client-handcode server-handcode
553 GetVisualFromFBConfigSGIX(dpy, config)
554 return XVisualInfoPointer
555 param dpy Display out reference
556 param config GLXFBConfigSGIX in value
557 category SGIX_fbconfig
558 glxflags client-handcode client-intercept server-handcode
560 GetFBConfigFromVisualSGIX(dpy, vis)
561 return GLXFBConfigSGIX
562 param dpy Display out reference
563 param vis XVisualInfo out reference
564 category SGIX_fbconfig
565 glxflags client-handcode client-intercept server-handcode
567 ###############################################################################
570 # SGIX_pbuffer commands
572 ###############################################################################
574 # ChangeDrawableAttributesSGIX protocol -> VendorPrivate opcode 65545
575 # GetDrawableAttributesSGIX protocol -> VendorPrivate opcode 65546
577 CreateGLXPbufferSGIX(dpy, config, width, height, attrib_list)
578 return GLXPbufferSGIX
579 param dpy Display out reference
580 param config GLXFBConfigSGIX in value
581 param width uint in value
582 param height uint in value
583 param attrib_list int out reference
584 category SGIX_pbuffer
585 glxflags client-handcode server-handcode
588 DestroyGLXPbufferSGIX(dpy, pbuf)
590 param dpy Display out reference
591 param pbuf GLXPbufferSGIX in value
592 category SGIX_pbuffer
593 glxflags client-handcode
596 QueryGLXPbufferSGIX(dpy, pbuf, attribute, value)
598 param dpy Display out reference
599 param pbuf GLXPbufferSGIX in value
600 param attribute int in value
601 param value uint out reference
602 category SGIX_pbuffer
604 SelectEventSGIX(dpy, drawable, mask)
606 param dpy Display out reference
607 param drawable GLXDrawable in value
608 param mask ulong in value
609 category SGIX_pbuffer
611 GetSelectedEventSGIX(dpy, drawable, mask)
613 param dpy Display out reference
614 param drawable GLXDrawable in value
615 param mask ulong out reference
616 category SGIX_pbuffer
618 ###############################################################################
621 # SGI_cushion commands
623 ###############################################################################
625 CushionSGI(dpy, window, cushion)
627 param dpy Display out reference
628 param window Window in value
629 param cushion float in value
632 ###############################################################################
635 # SGIX_video_resize commands
637 ###############################################################################
639 BindChannelToWindowSGIX(display, screen, channel, window)
641 param display Display out reference
642 param screen int in value
643 param channel int in value
644 param window Window in value
645 category SGIX_video_resize
647 ChannelRectSGIX(display, screen, channel, x, y, w, h)
649 param display Display out reference
650 param screen int in value
651 param channel int in value
656 category SGIX_video_resize
658 QueryChannelRectSGIX(display, screen, channel, dx, dy, dw, dh)
660 param display Display out reference
661 param screen int in value
662 param channel int in value
663 param dx int out reference
664 param dy int out reference
665 param dw int out reference
666 param dh int out reference
667 category SGIX_video_resize
669 QueryChannelDeltasSGIX(display, screen, channel, x, y, w, h)
671 param display Display out reference
672 param screen int in value
673 param channel int in value
674 param x int out reference
675 param y int out reference
676 param w int out reference
677 param h int out reference
678 category SGIX_video_resize
680 # @@@ Not in man page - this entry point may not be shipping?
681 ChannelRectSyncSGIX(display, screen, channel, synctype)
683 param display Display out reference
684 param screen int in value
685 param channel int in value
686 param synctype GLenum in value
687 category SGIX_video_resize
689 ###############################################################################
692 # SGIX_dmbuffer commands
694 ###############################################################################
696 newcategory: SGIX_dmbuffer
697 passthru: #ifdef _DM_BUFFER_H_
699 AssociateDMPbufferSGIX(dpy, pbuffer, params, dmbuffer)
701 param dpy Display out reference
702 param pbuffer GLXPbufferSGIX in value
703 param params DMparams out reference
704 param dmbuffer DMbuffer in value
705 category SGIX_dmbuffer
707 passend: #endif /* _DM_BUFFER_H_ */
710 ###############################################################################
713 # SGIX_swap_group commands
715 ###############################################################################
717 JoinSwapGroupSGIX(dpy, drawable, member)
719 param dpy Display out reference
720 param drawable GLXDrawable in value
721 param member GLXDrawable in value
722 category SGIX_swap_group
723 glxflags client-handcode server-handcode
726 ###############################################################################
729 # SGIX_swap_barrier commands
731 ###############################################################################
733 BindSwapBarrierSGIX(dpy, drawable, barrier)
735 param dpy Display out reference
736 param drawable GLXDrawable in value
737 param barrier int in value
738 category SGIX_swap_barrier
739 glxflags client-handcode server-handcode
742 QueryMaxSwapBarriersSGIX(dpy, screen, max)
744 param dpy Display out reference
745 param screen int in value
746 param max int out reference
747 category SGIX_swap_barrier
748 glxflags client-handcode server-handcode
751 ###############################################################################
754 # SUN_get_transparent_index commands
756 ###############################################################################
758 GetTransparentIndexSUN(dpy, overlay, underlay, pTransparentIndex)
760 param dpy Display out reference
761 param overlay Window in value
762 param underlay Window in value
763 param pTransparentIndex long out reference
764 category SUN_get_transparent_index
766 ###############################################################################
769 # MESA_copy_sub_buffer commands
771 ###############################################################################
773 CopySubBufferMESA(dpy, drawable, x, y, width, height)
775 param dpy Display out reference
776 param drawable GLXDrawable in value
779 param width int in value
780 param height int in value
781 category MESA_copy_sub_buffer
782 glxflags client-handcode client-intercept server-handcode
784 ###############################################################################
787 # MESA_pixmap_colormap commands
789 ###############################################################################
791 CreateGLXPixmapMESA(dpy, visual, pixmap, cmap)
793 param dpy Display out reference
794 param visual XVisualInfo out reference
795 param pixmap Pixmap in value
796 param cmap Colormap in value
797 category MESA_pixmap_colormap
798 glxflags client-handcode client-intercept server-handcode
800 ###############################################################################
803 # MESA_release_buffers commands
805 ###############################################################################
807 ReleaseBuffersMESA(dpy, drawable)
809 param dpy Display out reference
810 param drawable GLXDrawable in value
811 category MESA_release_buffers
812 glxflags client-handcode client-intercept server-handcode
814 ###############################################################################
817 # MESA_set_3dfx_mode commands
819 ###############################################################################
821 # Brian's spec has this as returning 'GLboolean' and taking 'GLint mode'
822 Set3DfxModeMESA(mode)
824 param mode int in value
825 category MESA_set_3dfx_mode
826 glxflags client-handcode client-intercept server-handcode
828 ###############################################################################
831 # SGIX_visual_select_group commands
833 ###############################################################################
836 newcategory: SGIX_visual_select_group
838 ###############################################################################
841 # OML_swap_method commands
843 ###############################################################################
846 newcategory: OML_swap_method
848 ###############################################################################
851 # OML_sync_control commands
853 ###############################################################################
855 GetSyncValuesOML(dpy, drawable, ust, msc, sbc)
857 param dpy Display out reference
858 param drawable GLXDrawable in value
859 param ust int64_t out reference
860 param msc int64_t out reference
861 param sbc int64_t out reference
862 category OML_sync_control
863 glxflags client-handcode server-handcode
865 GetMscRateOML(dpy, drawable, numerator, denominator)
867 param dpy Display out reference
868 param drawable GLXDrawable in value
869 param numerator int32_t out reference
870 param denominator int32_t out reference
871 category OML_sync_control
872 glxflags client-handcode server-handcode
874 SwapBuffersMscOML(dpy, drawable, target_msc, divisor, remainder)
876 param dpy Display out reference
877 param drawable GLXDrawable in value
878 param target_msc int64_t in value
879 param divisor int64_t in value
880 param remainder int64_t in value
881 category OML_sync_control
882 glxflags client-handcode server-handcode
884 WaitForMscOML(dpy, drawable, target_msc, divisor, remainder, ust, msc, sbc)
886 param dpy Display out reference
887 param drawable GLXDrawable in value
888 param target_msc int64_t in value
889 param divisor int64_t in value
890 param remainder int64_t in value
891 param ust int64_t out reference
892 param msc int64_t out reference
893 param sbc int64_t out reference
894 category OML_sync_control
895 glxflags client-handcode server-handcode
897 WaitForSbcOML(dpy, drawable, target_sbc, ust, msc, sbc)
899 param dpy Display out reference
900 param drawable GLXDrawable in value
901 param target_sbc int64_t in value
902 param ust int64_t out reference
903 param msc int64_t out reference
904 param sbc int64_t out reference
905 category OML_sync_control
906 glxflags client-handcode server-handcode
908 ###############################################################################
911 # NV_float_buffer commands
913 ###############################################################################
916 newcategory: NV_float_buffer
918 ###############################################################################
921 # SGIX_hyperpipe commands
923 ###############################################################################
925 newcategory: SGIX_hyperpipe
927 passthru: typedef struct {
928 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
929 passthru: int networkId;
930 passthru: } GLXHyperpipeNetworkSGIX;
932 passthru: typedef struct {
933 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
934 passthru: int channel;
935 passthru: unsigned int
936 passthru: participationType;
937 passthru: int timeSlice;
938 passthru: } GLXHyperpipeConfigSGIX;
940 passthru: typedef struct {
941 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
942 passthru: int srcXOrigin, srcYOrigin, srcWidth, srcHeight;
943 passthru: int destXOrigin, destYOrigin, destWidth, destHeight;
944 passthru: } GLXPipeRect;
946 passthru: typedef struct {
947 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
948 passthru: int XOrigin, YOrigin, maxHeight, maxWidth;
949 passthru: } GLXPipeRectLimits;
952 QueryHyperpipeNetworkSGIX(dpy, npipes)
953 return GLXHyperpipeNetworkSGIXPointer
954 param dpy Display out reference
955 param npipes int out reference
956 glxflags client-handcode server-handcode
957 category SGIX_hyperpipe
960 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
962 param dpy Display out reference
963 param networkId int in value
964 param npipes int in value
965 param cfg GLXHyperpipeConfigSGIX out array [COMPSIZE(npipes)]
966 param hpId int out reference
967 glxflags client-handcode server-handcode
968 category SGIX_hyperpipe
971 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
972 return GLXHyperpipeConfigSGIXPointer
973 param dpy Display out reference
974 param hpId int in value
975 param npipes int out reference
976 glxflags client-handcode server-handcode
977 category SGIX_hyperpipe
980 DestroyHyperpipeConfigSGIX(dpy, hpId)
982 param dpy Display out reference
983 param hpId int in value
984 glxflags client-handcode server-handcode
985 category SGIX_hyperpipe
988 BindHyperpipeSGIX(dpy, hpId)
990 param dpy Display out reference
991 param hpId int in value
992 glxflags client-handcode server-handcode
993 category SGIX_hyperpipe
996 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
998 param dpy Display out reference
999 param timeSlice int in value
1000 param attrib int in value
1001 param size int in value
1002 param attribList void out array [COMPSIZE(size)]
1003 param returnAttribList void out array [COMPSIZE(size)]
1004 glxflags client-handcode server-handcode
1005 category SGIX_hyperpipe
1008 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
1010 param dpy Display out reference
1011 param timeSlice int in value
1012 param attrib int in value
1013 param size int in value
1014 param attribList void out array [COMPSIZE(size)]
1015 glxflags client-handcode server-handcode
1016 category SGIX_hyperpipe
1019 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
1021 param dpy Display out reference
1022 param timeSlice int in value
1023 param attrib int in value
1024 param size int in value
1025 param returnAttribList void out array [COMPSIZE(size)]
1026 glxflags client-handcode server-handcode
1027 category SGIX_hyperpipe
1030 ###############################################################################
1033 # MESA_agp_offset commands
1035 ###############################################################################
1037 GetAGPOffsetMESA(pointer)
1039 param pointer void in reference
1040 glxflags client-handcode client-intercept server-handcode
1041 category MESA_agp_offset
1043 ###############################################################################
1046 # EXT_fbconfig_packed_float commands
1048 ###############################################################################
1051 newcategory: EXT_fbconfig_packed_float
1053 ###############################################################################
1056 # EXT_framebuffer_sRGB commands
1058 ###############################################################################
1061 newcategory: EXT_framebuffer_sRGB
1063 ###############################################################################
1066 # EXT_texture_from_pixmap commands
1068 ###############################################################################
1070 BindTexImageEXT(dpy, drawable, buffer, attrib_list)
1072 param dpy Display out reference
1073 param drawable GLXDrawable in value
1074 param buffer int in value
1075 param attrib_list int in reference
1076 category EXT_texture_from_pixmap
1077 glxflags client-handcode server-handcode
1080 ReleaseTexImageEXT(dpy, drawable, buffer)
1082 param dpy Display out reference
1083 param drawable GLXDrawable in value
1084 param buffer int in value
1085 category EXT_texture_from_pixmap
1086 glxflags client-handcode server-handcode
1089 ###############################################################################
1092 # NV_present_video commands
1094 ###############################################################################
1096 EnumerateVideoDevicesNV(dpy, screen, nelements)
1098 param dpy Display out reference
1099 param screen int in value
1100 param nelements int out reference
1101 category NV_present_video
1102 glxflags client-handcode server-handcode
1104 BindVideoDeviceNV(dpy, video_slot, video_device, attrib_list)
1106 param dpy Display out reference
1107 param video_slot uint in value
1108 param video_device uint in value
1109 param attrib_list int in reference
1110 category NV_present_video
1111 glxflags client-handcode server-handcode
1113 ###############################################################################
1116 # NV_video_output commands
1118 ###############################################################################
1120 GetVideoDeviceNV(dpy, screen, numVideoDevices, pVideoDevice)
1122 param dpy Display out reference
1123 param screen int in value
1124 param numVideoDevices int in value
1125 param pVideoDevice GLXVideoDeviceNV out array [COMPSIZE(numVideoDevices)]
1126 category NV_video_output
1127 glxflags client-handcode server-handcode
1129 ReleaseVideoDeviceNV(dpy, screen, VideoDevice)
1131 param dpy Display out reference
1132 param screen int in value
1133 param VideoDevice GLXVideoDeviceNV in value
1134 category NV_video_output
1135 glxflags client-handcode server-handcode
1137 BindVideoImageNV(dpy, VideoDevice, pbuf, iVideoBuffer)
1139 param dpy Display out reference
1140 param VideoDevice GLXVideoDeviceNV in value
1141 param pbuf GLXPbuffer in value
1142 param iVideoBuffer int in value
1143 category NV_video_output
1144 glxflags client-handcode server-handcode
1146 ReleaseVideoImageNV(dpy, pbuf)
1148 param dpy Display out reference
1149 param pbuf GLXPbuffer in value
1150 category NV_video_output
1151 glxflags client-handcode server-handcode
1153 SendPbufferToVideoNV(dpy, pbuf, iBufferType, pulCounterPbuffer, bBlock)
1155 param dpy Display out reference
1156 param pbuf GLXPbuffer in value
1157 param iBufferType int in value
1158 param pulCounterPbuffer ulong out reference
1159 param bBlock GLboolean in value
1160 category NV_video_output
1161 glxflags client-handcode server-handcode
1163 GetVideoInfoNV(dpy, screen, VideoDevice, pulCounterOutputPbuffer, pulCounterOutputVideo)
1165 param dpy Display out reference
1166 param screen int in value
1167 param VideoDevice GLXVideoDeviceNV in value
1168 param pulCounterOutputPbuffer ulong out reference
1169 param pulCounterOutputVideo ulong out reference
1170 category NV_video_output
1171 glxflags client-handcode server-handcode
1173 ###############################################################################
1176 # NV_swap_group commands
1178 ###############################################################################
1180 JoinSwapGroupNV(dpy, drawable, group)
1182 param dpy Display out reference
1183 param drawable GLXDrawable in value
1184 param group GLuint in value
1185 category NV_swap_group
1186 glxflags client-handcode server-handcode
1188 BindSwapBarrierNV(dpy, group, barrier)
1190 param dpy Display out reference
1191 param group GLuint in value
1192 param barrier GLuint in value
1193 category NV_swap_group
1194 glxflags client-handcode server-handcode
1196 QuerySwapGroupNV(dpy, drawable, group, barrier)
1198 param dpy Display out reference
1199 param drawable GLXDrawable in value
1200 param group GLuint out reference
1201 param barrier GLuint out reference
1202 category NV_swap_group
1203 glxflags client-handcode server-handcode
1205 QueryMaxSwapGroupsNV(dpy, screen, maxGroups, maxBarriers)
1207 param dpy Display out reference
1208 param screen int in value
1209 param maxGroups GLuint out reference
1210 param maxBarriers GLuint out reference
1211 category NV_swap_group
1212 glxflags client-handcode server-handcode
1214 QueryFrameCountNV(dpy, screen, count)
1216 param dpy Display out reference
1217 param screen int in value
1218 param count GLuint out reference
1219 category NV_swap_group
1220 glxflags client-handcode server-handcode
1222 ResetFrameCountNV(dpy, screen)
1224 param dpy Display out reference
1225 param screen int in value
1226 category NV_swap_group
1227 glxflags client-handcode server-handcode
1229 ###############################################################################
1232 # NV_video_capture commands
1234 ###############################################################################
1236 BindVideoCaptureDeviceNV(dpy, video_capture_slot, device)
1238 param dpy Display out reference
1239 param video_capture_slot uint in value
1240 param device GLXVideoCaptureDeviceNV in value
1241 category NV_video_capture
1242 glxflags client-handcode server-handcode
1244 EnumerateVideoCaptureDevicesNV(dpy, screen, nelements)
1245 return GLXVideoCaptureDeviceNVPointer
1246 param dpy Display out reference
1247 param screen int in value
1248 param nelements int out reference
1249 category NV_video_capture
1250 glxflags client-handcode server-handcode
1252 LockVideoCaptureDeviceNV(dpy, device)
1254 param dpy Display out reference
1255 param device GLXVideoCaptureDeviceNV in value
1256 category NV_video_capture
1257 glxflags client-handcode server-handcode
1259 QueryVideoCaptureDeviceNV(dpy, device, attribute, value)
1261 param dpy Display out reference
1262 param device GLXVideoCaptureDeviceNV in value
1263 param attribute int in value
1264 param value int out array [COMPSIZE(attribute)]
1265 category NV_video_capture
1266 glxflags client-handcode server-handcode
1268 ReleaseVideoCaptureDeviceNV(dpy, device)
1270 param dpy Display out reference
1271 param device GLXVideoCaptureDeviceNV in value
1272 category NV_video_capture
1273 glxflags client-handcode server-handcode
1275 ###############################################################################
1278 # EXT_swap_control commands
1280 ###############################################################################
1282 # Enums not assigned, extension not ready to publish yet
1283 # SwapIntervalEXT(dpy, drawable, interval)
1285 # param dpy Display out reference
1286 # param drawable GLXDrawable in value
1287 # param interval int in value
1288 # category EXT_swap_control
1289 # glxflags client-handcode server-handcode
1291 ###############################################################################
1294 # GLX_NV_copy_image commands
1296 ###############################################################################
1298 CopyImageSubDataNV(dpy, srcCtx, srcName, srcTarget, srcLevel, srcX, srcY, srcZ, dstCtx, dstName, dstTarget, dstLevel, dstX, dstY, dstZ, width, height, depth)
1300 param dpy Display out reference
1301 param srcCtx GLXContext in value
1302 param srcName GLuint in value
1303 param srcTarget GLenum in value
1304 param srcLevel GLint in value
1305 param srcX GLint in value
1306 param srcY GLint in value
1307 param srcZ GLint in value
1308 param dstCtx GLXContext in value
1309 param dstName GLuint in value
1310 param dstTarget GLenum in value
1311 param dstLevel GLint in value
1312 param dstX GLint in value
1313 param dstY GLint in value
1314 param dstZ GLint in value
1315 param width GLsizei in value
1316 param height GLsizei in value
1317 param depth GLsizei in value
1318 category NV_copy_image
1319 glxflags client-handcode server-handcode