1 # Copyright (C) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
3 # This document is licensed under the SGI Free Software B License Version
4 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
8 dlflags: notlistable handcode nop
9 glxflags: client-handcode server-handcode
12 category: pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
15 QueryExtension(dpy, errorb, event)
17 param dpy DisplayPointer in value
18 param errorb int out reference
19 param event int out reference
27 GetClientString(dpy, name)
29 param dpy DisplayPointer in value
30 param name int in value
31 ###############################################################################
35 ###############################################################################
40 glxflags client-handcode server-handcode
48 glxflags client-handcode server-handcode
52 CreateContext(dpy, visual, share_list, direct)
54 param dpy DisplayPointer in value
55 param visual XVisualInfoPointer in value
56 param share_list GLXContext in value
57 param direct Bool in value
58 glxflags client-handcode server-handcode
64 DestroyContext(dpy, ctx)
66 param dpy DisplayPointer in value
67 param ctx GLXContext in value
68 glxflags client-handcode server-handcode
74 MakeCurrent(dpy, drawable, ctx)
76 param dpy DisplayPointer in value
77 param drawable GLXDrawable in value
78 param ctx GLXContext in value
86 param dpy DisplayPointer in value
87 param ctx GLXContext in value
88 glxflags client-handcode server-handcode
94 QueryVersion(dpy, major, minor)
96 param dpy DisplayPointer in value
97 param major int out reference
98 param minor int out reference
101 glxflags client-handcode server-handcode
109 glxflags client-handcode server-handcode
117 glxflags client-handcode server-handcode
121 CopyContext(dpy, source, dest, mask)
123 param dpy DisplayPointer in value
124 param source GLXContext in value
125 param dest GLXContext in value
126 param mask ulong in value
129 glxflags client-handcode server-handcode
133 SwapBuffers(dpy, drawable)
135 param dpy DisplayPointer in value
136 param drawable GLXDrawable in value
139 glxflags client-handcode server-handcode
143 UseXFont(font, first, count, list_base)
145 param font Font in value
146 param first int in value
147 param count int in value
148 param list_base int in value
151 glxflags client-handcode server-handcode
155 CreateGLXPixmap(dpy, visual, pixmap)
157 param dpy DisplayPointer in value
158 param visual XVisualInfoPointer in value
159 param pixmap Pixmap in value
162 glxflags client-handcode server-handcode
169 glxflags client-handcode server-handcode
173 GetConfig(dpy, visual, attribute, value)
175 param dpy DisplayPointer in value
176 param visual XVisualInfoPointer in value
177 param attribute int in value
178 param value int out reference
181 DestroyGLXPixmap(dpy, pixmap)
183 param dpy DisplayPointer in value
184 param pixmap GLXPixmap in value
185 glxflags client-handcode
193 glxflags client-handcode server-handcode
199 VendorPrivateWithReply()
201 glxflags client-handcode server-handcode
206 ###############################################################################
210 ###############################################################################
211 QueryExtensionsString(dpy, screen)
213 param dpy DisplayPointer in value
214 param screen int in value
215 glxflags client-handcode server-handcode
220 QueryServerString(dpy, screen, name)
222 param dpy DisplayPointer in value
223 param screen int in value
224 param name int in value
225 glxflags client-handcode server-handcode
232 glxflags client-handcode server-handcode
237 ###############################################################################
241 ###############################################################################
242 GetFBConfigs(dpy, screen, nelements)
243 return GLXFBConfigPointer
244 param dpy DisplayPointer in value
245 param screen int in value
246 param nelements int out reference
249 glxflags client-handcode server-handcode
252 CreatePixmap(dpy, config, pixmap, attriblist)
254 param dpy DisplayPointer in value
255 param config GLXFBConfig in value
256 param pixmap Pixmap in value
257 param attriblist int in array
259 glxflags client-handcode server-handcode
263 DestroyPixmap(dpy, pixmap)
265 param dpy DisplayPointer in value
266 param pixmap Pixmap in value
268 glxflags client-handcode server-handcode
272 CreateNewContext(dpy, config, render_type, share_list, direct)
274 param dpy DisplayPointer in value
275 param config GLXFBConfig in value
276 param render_type int in value
277 param share_list GLXContext in value
278 param direct Bool in value
280 glxflags client-handcode server-handcode
284 QueryContext(dpy, context, attribute, value)
286 param dpy DisplayPointer in value
287 param context GLXContext in value
288 param attribute int in value
289 param value int out reference
291 glxflags client-handcode server-handcode
295 MakeContextCurrent(dpy, drawdrawable, readdrawable, context)
297 param dpy DisplayPointer in value
298 param drawdrawable GLXDrawable in value
299 param readdrawable GLXDrawable in value
300 param context GLXContext in value
302 glxflags client-handcode server-handcode
306 CreatePbuffer(dpy, config, attrib_list)
308 param dpy DisplayPointer in value
309 param config GLXFBConfig in value
310 param attrib_list int in array
312 glxflags client-handcode server-handcode
316 DestroyPbuffer(dpy, pbuffer)
318 param dpy DisplayPointer in value
319 param pbuffer GLXPbuffer in value
321 glxflags client-handcode
325 GetDrawableAttributes(drawable)
327 param drawable int in value
329 glxflags client-handcode server-handcode
333 ChangeDrawableAttributes(drawable)
335 param drawable int in value
337 glxflags client-handcode server-handcode
341 CreateWindow(dpy, config, window, attrib_list)
343 param dpy DisplayPointer in value
344 param config GLXFBConfig in value
345 param window Window in value
346 param attrib_list int in array
348 glxflags client-handcode server-handcode
352 DestroyWindow(dpy, window)
354 param dpy DisplayPointer in value
355 param window Window in value
357 glxflags client-handcode server-handcode
361 ChooseVisual(dpy, screen, attriblist)
362 return XVisualInfoPointer
363 param dpy DisplayPointer in value
364 param screen int in value
365 param attriblist int out array
368 ###############################################################################
370 # IRIX5.3 extension commands
372 ###############################################################################
374 ###############################################################################
376 # SGI_swap_control extension commands
378 ###############################################################################
381 glxflags client-handcode server-handcode
386 ###############################################################################
388 # IRIX5.3-PATCH154 extension commands
390 ###############################################################################
392 ###############################################################################
394 # SGI_make_current_read extension commands
396 ###############################################################################
397 MakeCurrentReadSGI(drawable, readdrawable, context)
399 param drawable Int32 in value
400 param readdrawable Int32 in value
401 param context Int32 in value
402 glxflags client-handcode server-handcode
407 ###############################################################################
409 # SGIX_video_source extension commands
411 ###############################################################################
412 CreateGLXVideoSourceSGIX(dpy, screen, server, path, class, node)
414 param dpy Int32 in value
415 param screen Int32 in value
416 param server Int32 in value
417 param path Int32 in value
418 param class Int32 in value
419 param node Int32 in value
420 glxflags client-handcode server-handcode
425 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
427 param dpy Int32 in value
428 param glxvideosource Int32 in value
429 glxflags client-handcode server-handcode
434 ###############################################################################
436 # IRIX6.2 extension commands
438 ###############################################################################
440 ###############################################################################
442 # EXT_import_context extension commands
444 ###############################################################################
445 QueryContextInfoEXT(dpy, context, attribute, value)
447 param dpy DisplayPointer in value
448 param context GLXContext in value
449 param attribute Int32 in value
450 param value Int32 out reference
453 glxflags client-handcode server-handcode
456 ###############################################################################
458 # SGIX_fbconfig extension commands
460 ###############################################################################
465 glxflags client-handcode server-handcode
468 CreateContextWithConfigSGIX(dpy, config, renderType, share_list, allow_direct)
470 param dpy DisplayPointer in value
471 param config GLXFBConfigSGIX in value
472 param renderType Int32 in value
473 param share_list GLXContext in value
474 param allow_direct Bool in value
475 glxflags client-handcode server-handcode
480 CreateGLXPixmapWithConfigSGIX(dpy, config, pixmap, attriblist)
482 param dpy DisplayPointer in value
483 param config GLXFBConfigSGIX in value
484 param pixmap Pixmap in value
485 param attriblist Int32 in array
488 glxflags client-handcode server-handcode
491 ###############################################################################
493 # SGIX_pbuffer extension commands
495 ###############################################################################
497 CreateGLXPbufferSGIX(dpy, config, width, height, attriblist)
499 param dpy DisplayPointer in value
500 param config GLXFBConfig in value
501 param width UInt32 in value
502 param height UInt32 in value
503 param attriblist Int32 in array
505 glxflags client-handcode server-handcode
509 DestroyGLXPbufferSGIX(dpy, pbuffer)
511 param dpy DisplayPointer in value
512 param pbuffer GLXPbuffer in value
514 glxflags client-handcode
518 ChangeDrawableAttributesSGIX(drawable)
520 param drawable Int32 in value
522 glxflags client-handcode server-handcode
526 GetDrawableAttributesSGIX(drawable)
528 param drawable Int32 in value
530 glxflags client-handcode server-handcode
534 ###############################################################################
536 # SGIX_swap_group extension commands
538 ###############################################################################
540 JoinSwapGroupSGIX(dpy, drawable, member)
542 param dpy DisplayPointer in value
543 param drawable GLXDrawable in value
544 param member GLXDrawable in value
545 glxflags client-handcode server-handcode
550 ###############################################################################
552 # SGIX_swap_barrier extension commands
554 ###############################################################################
556 BindSwapBarrierSGIX(dpy, drawable, barrier)
558 param dpy DisplayPointer in value
559 param drawable GLXDrawable in value
560 param barrier Int32 in value
561 glxflags client-handcode server-handcode
566 QueryMaxSwapBarriersSGIX(dpy, screen, max)
568 param dpy DisplayPointer in value
569 param screen Int32 in value
570 param max Int32 out value
571 glxflags client-handcode server-handcode
576 ###############################################################################
578 # SGIX_hyperpipe extension commands
580 ###############################################################################
582 QueryHyperpipeNetworkSGIX(dpy, npipes)
583 return GLXHyperpipeNetworkPointer
584 param dpy Display out reference
585 param npipes int out reference
586 glxflags client-handcode server-handcode
591 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
593 param dpy Display out reference
594 param networkId int in value
595 param npipes int in value
596 param cfg GLXHyperpipeConfig in array[npipes]
597 param hpId int out reference
598 glxflags client-handcode server-handcode
603 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
604 return GLXHyperpipeConfigPointer
605 param dpy Display out reference
606 param hpId int in value
607 param npipes int out reference
608 glxflags client-handcode server-handcode
613 DestroyHyperpipeConfigSGIX(dpy, hpId)
615 param dpy Display out reference
616 param hpId int in value
617 glxflags client-handcode server-handcode
622 BindHyperpipeSGIX(dpy, hpId)
624 param dpy Display out reference
625 param hpId int in value
626 glxflags client-handcode server-handcode
631 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
633 param dpy Display out reference
634 param timeSlice int in value
635 param attrib int in value
636 param size int in value
637 param attribList Void in array[size]
638 param returnAttribList Void out array[size]
639 glxflags client-handcode server-handcode
644 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
646 param dpy Display out reference
647 param timeSlice int in value
648 param attrib int in value
649 param size int in value
650 param attribList void in array[size]
651 glxflags client-handcode server-handcode
656 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
658 param dpy Display out reference
659 param timeSlice int in value
660 param attrib int in value
661 param size int in value
662 param returnAttribList void in array[size]
663 glxflags client-handcode server-handcode