Recognize #version directive in GLSL
authorMikko Rasa <tdb@tdb.fi>
Thu, 11 Jul 2019 22:22:59 +0000 (01:22 +0300)
committerMikko Rasa <tdb@tdb.fi>
Thu, 11 Jul 2019 22:22:59 +0000 (01:22 +0300)
commit53dac3ba3cb3a1e4ed23d5fa459187acde7a4904
tree6b6176e0934f02a89fba74b9391ab01941dcae6f
parentdad209400d4e5d39076d949364f598b854c7a5d7
Recognize #version directive in GLSL

This allows shaders to explicitly specify the required version in
case there's a feature which is not detected by the program compiler
framework.
source/programcompiler.cpp
source/programparser.cpp
source/programparser.h